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Typographic controls

Most of Illustrator’s default set-

tings for type are controlled in the 

Type & Auto Tracing area of Pref-

erences. One exception is the unit 

of measurement for type, which 

is set in Preferences > Units & Dis-

play Performance.

Selecting type by accident

If you keep accidentally selecting 

type when you’re trying to select 

an object with the Selection tool, 

enable Type Object Selection by 

Path Only (Preferences > Type & 

Auto Tracing). With this option 

turned on, you won’t select type 

objects unless you click directly 

on the baseline or path of the 

type. (If you have trouble finding 

the path, you can select the text 

object in the Layers palette, or 

marquee at least a full letterform 

with a selection tool or the Lasso 

tool.)

The Type tool, Area Type tool, Path Type tool, 
Vertical Type tool, Vertical Area Type tool, and 
Vertical Path Type tool. Select a Type tool and 
press Shift to toggle the tool between a hori-
zontal and vertical orientation

Type

With the arrival of Illustrator CS, Illustrator users have 
taken a big step forward in terms of the control and 
sophistication with which they can design type. In addi-
tion to Illustrator’s new Type engine itself, the most 
momentous new developments are the arrival of para-
graph and character styles; increased support for Open-
Type fonts that allows you to take full advantage of their 
superior capabilities; and new features that help you cre-
ate more aesthetically pleasing text layouts by increasing 
your control over text blocks, columns and rows, and the 
spacing and alignment of characters. Adobe rounds out 
the package with a wealth of smaller and less easily cat-
egorizable features that will help make the experience of 
designing type in Illustrator more satisfying.

Although you’ll probably still prefer a page layout 
program such as QuarkXPress, InDesign, or Page-
Maker for multi-page documents like catalogues and 
long magazine articles, and Dreamweaver or GoLive for 
Web page layout, this chapter will demonstrate many 
reasons to stay within Illustrator for single-page docu-
ments. The Type chapter of Adobe’s User Guide covers 
the creation and manipulation of type in great detail, so 
this introduction will focus on essentials, what’s new and 
production tips.

For creating and manipulating type, Illustrator CS 
offers no less that seven palettes, all accessible from 
the Window > Type submenu. Nested in with the old 
Paragraph and Character palettes is the new OpenType 
palette, which gives you convenient access to the options 
of OpenType fonts. The new Glyphs palette lets you 
choose quickly from a wide range of special characters. 
The new Character Styles and Paragraph Styles palettes, 
nested together, are where you’ll manage Illustrator’s 
new automatic text formatting capabilities. And the new, 
improved Tabs palette replaces the old Tab Ruler.

When you first open the Character and Paragraph 
palettes, they may appear in a collapsed view. To cycle 
through display options for either palette, click the dou-
ble arrow on the Palette tab.

There are three type options in Illustrator that are 

accessible through the Type tool: Point type, Area type, 

and Path type. The flexible Type tool lets you click to 

create a Point type object, click-drag to create an Area 

type object, click within any existing type object to 

enter or edit text, or click on a path to create Path type 

(discussed a bit further on). You can gain access to type 

created in other applications by using the File > Open or 

File > Place commands (and of course by using the Copy 

and Paste commands).

Select letters, words or an entire block of text by 

dragging across the letters with the Type tool, or use a 

selection tool to select text as an object by clicking on  

or marqueeing the text baseline (the baseline is the  

line that the type sits on).

• Point type: Click with the Type tool or the Vertical 

Type tool anywhere on the page to create Point type. 

Once you click, a blinking text-insertion cursor called 

an “I-beam” indicates that you can now type text using 

your keyboard. To add another line of text, press the 

Return/Enter key. When you’re finished typing into 

one text object, click on the Type tool in the Toolbox to 

simultaneously select the current text as an object (the I-

beam will disappear) and be poised to begin another text 

object. To just select the text as an object, click on a selec-

tion tool.

• Area type: Click and drag with the Type tool to create a 

rectangle, into which you can type. Once you’ve defined 

your rectangle, the I-beam awaits your typing, and the 

text automatically wraps to the next line when you type 

in the confines of the rectangle.

Another way to create Area type or Vertical Area 
type is to construct a path (with any tools you wish) 

It’s Greek to me!

You can specify a size at which 

type will be “greeked” on screen 

(which means it will appear as gray 

bars rather than readable text). 

Set the greeking size by choosing 

Preferences > Type & Auto Tracing, 

and entering a size in the Greek-

ing field. Text at or below that size 

will be greeked. Note that greeked 

text prints normally. 

Selecting text or objects

Once you’ve entered your text, 

use the Type tool to select any 

text element by clicking and drag-

ging across letters, words, or lines; 

double-clicking to select a word; 

triple-clicking to select a para-

graph; or Shift-clicking to extend 

a selection. If the text-insertion 

I-beam is activated, then Edit > 

Select All selects all type within 

that text object. Otherwise, Select 

All selects all unlocked objects in 

your image.
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forming a shape within which to place the type. Click 
and hold on the Type tool to access other tools, or press 
the Shift key to toggle between horizontal and vertical 
orientations of like tools (see Tip “Type tool juggling” 
later in this chapter introduction). Choose the Area Type 
or Vertical Area Type tool and click on the path itself to 
place text within the path. Distort the confining shape by 
grabbing an anchor point with the Direct Selection tool 
and dragging it to a new location, or reshape the path by 
adjusting direction lines. The text within will reflow.
Note: If you use the Vertical Area Type tool, you’ll see 
that your text will flow automatically, starting from the 
right edge of the area flowing toward the left! Those of you 
who use Roman fonts and typographic standards won’t 
have much use for this tool since Roman type flows from 
left to right (see the Tip “Multinational font support” later 
in this chapter.)

Illustrator’s new Area Type Options dialog box (Type 

> Area Type Options) gives you precise control over a 

number of important aspects of Area type. You can set 

numerical values for the width and height of the selected 

Area type; set precise values for Rows and Columns 

(i.e. you can divide a single Area type object into mul-

tiple columns or rows that will reflow as you type), and 

choose whether or not those values remain fixed as you 

scale; specify Offset options, including the amount of 

inset (defined as the margin between the text and the 

bounding path) and the alignment of the first baseline 

of text; and a Text Flow option that determines how text 

flows between rows or columns.

To set tabs for Area type, select the text object and 

choose Window > Type > Tabs. The Tabs palette (new 

in Illustrator CS) will open aligned with the text box. 

As you pan or zoom, you’ll notice the Tab ruler doesn’t 

move with the text box. No sweat: If you lose your align-

ment, just click the little Magnet button on the Tabs pal-

ette, and the palette will snap back into alignment. 

One new feature that arrives with the Tabs palette is 

the ability to create your own tab leaders. A tab leader is 

a repeated pattern of characters (such as dots or dashes) 

between a Tab and the text that follows it. Select a tab 

stop on the ruler in the Tabs palette, type a pattern of up 

to eight characters in the palette’s Leader box, then hit 

Return/Enter. You’ll see your customized Leader pattern 

repeated across the width of the tab. (For more on using 

the Tabs palette, see the User Guide.)

• Path type: The Path type tool allows you to click on a 

path to flow text along the perimeter of the path (the 

path will then become unstroked or unfilled). 

Illustrator CS adds a new level of control over Path 

type. When you select a Path type object, you’ll see three 

brackets appear: one at the beginning, one in the center, 

and one at the end of the Path type. The beginning and 

end brackets carry an in port and an out port, respec-

tively, which can be used to thread text between objects 

(see the Tip “Ports illustrated”). The center bracket is 

used to control the positioning of the Path type. Hold 

your cursor over it until a small icon that looks like an 

upside down T appears. You can now drag the center 

bracket to reposition the type. Dragging the bracket 

across the path will f lip the type to the other side of the 

path. (For example, type along the outside of a circle 

would flip to the inside.) Dragging the bracket forward 

or backward along the direction of the path will move 

the type in that direction.

As with Area type, use the Direct Selection tool to 
reshape the confining path; the type on the path will 
automatically readjust to the new path shape.

The new Type on a Path Options dialog box (Type > 
Type on a Path > Type On a Path Options) lets you set a 
number of Path type attributes. You can choose from five 
different Path Type Effects (Rainbow, Skew, 3D Ribbon, 
Stair Step, and Gravity); a Flip checkbox that will auto-
matically flip type to the other side of the path; a menu 
that lets you set the alignment of type relative to the 
path; and a Spacing control that lets you adjust the spac-
ing of type as it moves around a curve. (The Path Type 

Ports illustrated

Each type object in Illustrator CS 

has an in port (a small box at the 

upper left side) and an out port (a 

small box at the lower right side). 

If both ports are empty, all the 

text is displayed and the object 

isn’t currently linked (or threaded) 

to any other text objects. You may 

also see the following symbols in 

the ports: 

• A red plus sign in the out port 

means the object contains over-
flow text (additional text that 

doesn’t fit)

• An arrow in the in port means 

the object is threaded to a pre-

ceding text object, and text is 

flowing into the current object

• An arrow in the out port means 

the object is threaded to a sub-

sequent text object, and text 

is flowing out of the current 

object.

Tabs palette

Area Type Options dialog box

To manually flip type on a path to the other side 
of the path, select the type and drag the center 
handle (the thin blue line perpendicular to the 
type) across the path, as indicated by the red 
arrow above. Note the tiny T-shaped icon that 
appears next to the cursor as you position it 
near the handle

The same type, after dragging across the path, 
but before releasing the mouse. After release, 
the type will be in the position indicated by the 
blue type above the path. You can then drag 
the center handle from side to side to adjust 
the position of the text—just don’t drag across 
the path again or you’ll flip the type back. You 
can also flip type across a path automatically 
by choosing Type > Type on a Path > Type on a 
Path Options, checking the Flip box (as shown 
on the following page), and clicking on OK

Object rows and columns 

Wondering how to create rows 

and columns from non-type 

objects? Just select the object(s) 

and choose Object > Path > Split 

into Grid. 

Rectangle rule relaxed 

One nice improvement in Illustra-

tor CS is that when you use the 

Area Type Options dialog box to 

create rows and columns, your 

type container won’t get auto-

matically converted to a rectangle 

(as was the case with the Rows 

and Columns function in previous 

versions of Illustrator). 
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The Type on a Path Options dialog box 

The Type on a Path submenu

Effects are also available via the Type > Type on a Path 
submenu.) See the User Guide for in-depth info.

WORKING WITH THREADED TEXT 
If a text object contains more text than it has room to 

display, you’ll see a plus sign in the small box along its 

lower right side. (This box is called the out port; see the 

Tip “Ports illustrated,” earlier in this chapter.) To enlarge 

the object to allow for more text, use the Selection tool 

to grab the object and resize it (hold down the Shift key 

if you want to constrain proportions as you resize). 

To add a new text object that can receive overflow 
text, use the Selection tool to select the first text object. 
Next, click on the red plus sign in the out port. The cur-
sor will change to the “loaded text” cursor, which looks 
like a miniature text block. Then you can either click 
on the Artboard to create a new text object the same 
size and shape as the original; or drag to create a text 
object of any size. Either way, the new text object will 
be threaded (linked) to the original, and the text that 
wouldn’t fit in the first object will flow into the second.
Note: Make sure Type Object Selection by Path Only is 
unchecked in the Type & Auto Tracing area of Preferences, 
or the above process won’t work.

Similarly, you can link existing text objects together 
by clicking the plus sign on the first object, and then 
clicking on the path of the object that is to receive the 
overflow text. (Keep your eye on the cursor, which will 
change to indicate valid “drop” locations.) You can also 
link objects using a menu command: Select the first 
object with the Selection tool, then Shift-click to select 
the second object as well. Choose Type > Threaded Text 
> Create, and voilà, the objects are linked.

Of course, the threads between objects can be broken 
as easily as they’re created. If you want to disconnect one 
object from another, first select the object. Then double-
click its in port to break the thread to a preceding object, 
or double click its out port to break the thread to a sub-
sequent object. Alternatively, you can select the object 

and click either the in port or the out port once. Then 
click the other end of the thread to break it.

You can also release an object from a Text thread 
by selecting it, then choosing Type > Threaded Text > 
Release Selection. Or, if you want to remove the thread-
ing from an object while leaving text in place, select it 
and choose Type > Threaded Text > Remove Threading.

WRAPPING TEXT AROUND OBJECTS

Illustrator CS handles text wrapping a little differently 

than previous versions. Text wrapping is now an object 

attribute and is set specifically for each object that will 

have text wrapped around it (known as a wrap object). 

First, make sure that the object you want to wrap text 

around is above the text you want to wrap around it 

in the Layers palette. Then select the wrap object and 

choose Object > Text Wrap > Make Text Wrap. The 

Text Wrap Options dialog box will appear. Here, you’ll 

choose the amount of offset and also have the option to 

choose Invert Wrap (which reverses the side of the object 

that text wraps around). You can also wrap text around 

a group of objects. In order to add a new object to the 

textwrapped group, just drag its Layers palette entry into 

the group. To release an object from text wrapping, select 

it and choose Object > Text Wrap > Release Text Wrap. 

To change the options for an existing wrap object, select 

it and choose Object > Text Wrap > Text Wrap Options. 

(For more on text wrapping, see the User Guide.)

CHARACTER AND PARAGRAPH STYLES 
As in previous versions, Illustrator’s Character and 

Paragraph palettes (Window > Type > Character and 

Window > Type > Paragraph) let you format text by 

changing one attribute at a time. Illustrator CS takes for-

matting to the next level by introducing Character and 

Paragraph styles. Now you can apply multiple attributes 

to text simply by applying the appropriate style.

Making a new text object

Reselect the Type tool to end one 

text object; the next click will start 

a new text object. Or, deselect 

the current text by holding down 

the C (Mac)/Ctrl (Win) key (tem-

porarily turning your cursor into 

a selection tool) and clicking out-

side the text block.

The quick-changing Type tool

When using the regular Type

 tool, look at your cursor very 

carefully in these situations:

• If you move the regular 

Type tool over a closed 

path, the cursor changes 

 to the Area-type icon. 

• If you move the Type tool 

 over an open path, the  

cursor will change to the  

Path-type icon.

Type tool juggling

To toggle a Type tool between 

its vertical and horizontal mode, 

first make sure nothing is selected. 

Hold the Shift key down to toggle 

the tool to the opposite mode. 

The upper text object is threaded (linked) to the 
lower one. The blue line connects the out port 
of the upper object to the in port of the lower 
one, showing that the two objects are threaded 
together; text thus flows from the first object to 
the second. The red plus sign in the out port of 
the lower object indicates that there is still more 
overflow text, which could flow into a third 
threaded object

Path type and closed paths 

Keep in mind that Path type can 

be applied to both open and 

closed paths—even though the 

feedback you get from your cursor 

may seem to indicate that it can 

only be applied to open paths. 

Hiding text threads

Users of page layout programs like 

InDesign or QuarkXPress will rec-

ognize the way Illustrator shows 

text threads graphically, by draw-

ing a line between linked objects. 

If this visual gets in the way, you 

can toggle it on and off via View > 

Show/Hide Text Threads.




